MySQL error 1364 Field doesn’t have a default values

Od  wersji 5.7 serwera MySQL parametr strict mode jest domyślnie ustawiony w jego konfiguracji po instalacji serwera. W konsekwencji tego, jeśli pola nie mają ustawionej domyślnej wartości, występuje błąd zapisu danych do bazy.

Mamy dwa wyjścia: możemy zaktualizować aplikację i ustawić dla wszystkich pól w bazie danych domyślne wartości, albo zmienić konfigurację serwera.

Wybierając drugie rozwiązanie edytujemy plik /etc/mysql/my.cnf Czytaj dalej MySQL error 1364 Field doesn’t have a default values

MySQL sql_mode=only_full_group_by error

W przypadku wystąpienia w mysql błędu:

„this is incompatible with sql_mode=only_full_group_by”

należy na końcu pliku /etc/mysql/mysql.conf.d/mysqld.cnf dopisać poniższą linię:

sql_mode = "STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

i zrestartować serwer MySQL:

root@server:/# systemctl restart mysql

Dovecot: Inotify instance limit for user exceeded, disabling – erro

Jeśli w pliku mail.log pojawiają nam się ostrzeżenia: Warning: Inotify instance limit for user xxxx (UID vmail) exceeded, disabling. Increase /proc/sys/fs/inotify/max_user_instances należy zwiększyć wartość parametru max_user_instances.

Wyświetlenie aktualnie używanych parametrów:

root@server:/# sysctl -a | grep inotyfi.max

Zmiana wartości domyślnej. Edytujemy plik /etc/sysctl.conf: Czytaj dalej Dovecot: Inotify instance limit for user exceeded, disabling – erro

MS Office 2013 print problem

Podczas drukowania z programów MS Office 2013 (Word, Excell, Power Point i innych) może się zdarzyć, że program przestanie odpowiadać. Powodem tego mogą być dodatki domyślnie włączone w Office.

Jeśli chcecie pracować w programach z pakietu Office 2013 beza żadnych problemów, proponuję wyłączyć wszystkie dodatki według poniższego opisu:

1) W Wordzie należy wybrać Plik -> Opcje -> Dodatki,

2) Na dole w opcji zarządzanie należy wybrać Dodatki COM i klikną Czytaj dalej MS Office 2013 print problem

Instalacja bibliteki GD PHP 5 w Ubuntu

Jeśli integrujecie Uploadify z jQuery UI ze swoją stroną www i pojawia Wam się błąd „HTTP Error” lub chcecie skorzystać z funkcji imagecreatefromjpeg(), która nie działa, a w logach jest wpis „Call to undefined function imagecreatefromjpeg()” bardzo możliwe, że nie macie zainstalowanej biblioteki GD z PHP. Można to sprawdzić dodając do strony www napisanej w PHP poniższy wpis:

echo "<pre>"; print_r(gd_info()); echo "</pre>";

Jeśli wyświetlając stronę w przeglądarce otrzymamy wynik różny od poniższego:

Array
(
    [GD Version] => 2.0
    [FreeType Support] => 1
    [FreeType Linkage] => with freetype
    [T1Lib Support] => 1
    [GIF Read Support] => 1
    [GIF Create Support] => 1
    [JPEG Support] => 1
    [PNG Support] => 1
    [WBMP Support] => 1
    [XPM Support] =>
    [XBM Support] =>
    [JIS-mapped Japanese Font Support] =>
)

lub nie otrzymamy nic oznacza to, że musicie zainstalować bibliotekę GD w systemie. W tym celu wystarczy wydać poniższe polecenie z konsoli:

root@server:# apt-get install php5-gd

Pamiętajcie, aby przed instalacją biblioteki wykonać aktualizację systemu wydając poniższe polecenia:

root@server:# apt-get update
root@server:# apt-get upgrade

Po instalacji należy zrestartować serwer www wydając polecenie:

root@server:# /etc/init.d/apache2 restart

Jeśli dalej występują błędy, powodem jest coś innego, szukajcie na tym forum, powinno być rozwiązanie.