Instalacja bibliteki GD PHP 5 w Ubuntu

Jeśli integrujecie Uploadify z jQuery UI ze swoją stroną www i pojawia Wam się błąd „HTTP Error” lub chcecie skorzystać z funkcji imagecreatefromjpeg(), która nie działa, a w logach jest wpis „Call to undefined function imagecreatefromjpeg()” bardzo możliwe, że nie macie zainstalowanej biblioteki GD z PHP. Można to sprawdzić dodając do strony www napisanej w PHP poniższy wpis:

echo "<pre>"; print_r(gd_info()); echo "</pre>";

Jeśli wyświetlając stronę w przeglądarce otrzymamy wynik różny od poniższego:

Array
(
    [GD Version] => 2.0
    [FreeType Support] => 1
    [FreeType Linkage] => with freetype
    [T1Lib Support] => 1
    [GIF Read Support] => 1
    [GIF Create Support] => 1
    [JPEG Support] => 1
    [PNG Support] => 1
    [WBMP Support] => 1
    [XPM Support] =>
    [XBM Support] =>
    [JIS-mapped Japanese Font Support] =>
)

lub nie otrzymamy nic oznacza to, że musicie zainstalować bibliotekę GD w systemie. W tym celu wystarczy wydać poniższe polecenie z konsoli:

root@server:# apt-get install php5-gd

Pamiętajcie, aby przed instalacją biblioteki wykonać aktualizację systemu wydając poniższe polecenia:

root@server:# apt-get update
root@server:# apt-get upgrade

Po instalacji należy zrestartować serwer www wydając polecenie:

root@server:# /etc/init.d/apache2 restart

Jeśli dalej występują błędy, powodem jest coś innego, szukajcie na tym forum, powinno być rozwiązanie.